Customers are experiencing issues with sending private messages on Twitter/X channels
Incident Report for RingCentral Engage Digital
Resolved
Our team has rolled out a fix for this issue. Situation is now back to normal.
If you're still experiencing issues on Twitter/X DMs, please reach out to our Support team.
Posted Feb 02, 2024 - 23:00 CET
Identified
Due to limitations on Twitter/X's APIs, a portion of Engage Digital customers may experience issues and delays with sending private messages (outbound only).
If you're experiencing issues, please reach out to our Support team.
Posted Feb 02, 2024 - 15:13 CET
This incident affected: Source Synchronization (X/Twitter synchronization).