Issue with Twitter/X channels
Incident Report for RingCentral Engage Digital
Resolved
Situation is back to normal, channels are correctly synchronized.
If you're experiencing any issue, please reach out to our support team.
Posted Dec 20, 2023 - 15:49 CET
Monitoring
Synchronization has resumed on impacted channels.
Our teams are still monitoring the situation and are waiting for more information from X teams to identify the root cause.
If you're experiencing any issue, please reach out to our support team.
Posted Dec 20, 2023 - 15:05 CET
Investigating
A portion of Engage Digital customers may experience issues with receiving and sending messages on Twitter/X channels.
Our teams are investigating the root cause and are checking with X teams
Posted Dec 20, 2023 - 11:37 CET
This incident affected: Source Synchronization (X/Twitter synchronization).