Facebook Messenger not delivering attachments from customers (images & more) to ED
Incident Report for RingCentral Engage Digital
Resolved
Facebook has not closed its issue yet but announced it's resolved 10h ago. Volume of received attachments are normal.

Please contact support if you still notice any issue.
Posted Nov 24, 2020 - 11:03 CET
Monitoring
Facebook deployed a fix a couple hours ago, the situation seems back to normal, we are monitoring the situation.
Posted Nov 24, 2020 - 10:12 CET
Identified
Messenger Facebook API (webhook) is not always delivering the attachments pushed by customers whatever their type is (image or else) to Engage Digital. The effect on Engage Digital is that most attachments are silently NOT imported in Engage Digital and neither the customer nor the agent is aware of that.

It's an identified bug on Facebook side https://developers.facebook.com/support/bugs/393441492018560/ that is suddenly getting a lot of traction as situation seem to be getting worse and worse (meaning less and less attachments are delivered by Facebook).

As far as we can tell most pages are impacted but messages with attachments sent from Engage Digital are properly delivered to customers.

We are monitoring the situation closely and trying to escalate it to Facebook so that it get resolved as far as possible.
Posted Nov 23, 2020 - 18:27 CET
This incident affected: Source Synchronization (Messenger synchronization).